PROBLEA Retropie+Attrct Mode+ Driver GPIO

Tutti gli emulatori che ci possono servire sul nostro cab con SO non Windows

Moderatore: Moderatore Raspberry

artfunk
Affezionato
Affezionato
Messaggi: 187
Iscritto il: 08/03/2013, 14:08
Reputation: 0
Città: Roma

PROBLEA Retropie+Attrct Mode+ Driver GPIO

Messaggio da artfunk » 27/08/2017, 14:32

Scusate se apro un nuovo post per parlare di cose che ho già scritto in altri post che ho aperto, ma sono giorni che COMBATTO con questi problemi, e nonostante le decine di guide e tutorial seguiti, non ne vengo a capo.

Allora ho deciso di mettere su un arcade joystick basato su raspberry Pi3, quindi ho comprato l'occorrente e ho iniziato a documentarmi.
Sono partito installando l'immagine Retropie 4.2 pulita https://retropie.org.uk/download/ su cui ho poi eseguito l'installazione del driver GPIO seguendo la guida di devil78
viewtopic.php?f=79&t=22809
In 3 minuto riesco a configurare tutto e tutto funziona alla grande, sono riuscito a configurare diversi emulatori compreso il Daphne senza problemi e tutto va bene.
Poi ho deciso di asplorare Attract Mode, così ho scaricato diverse immagini già pronte, ma su nessuna c'è il driver GPIO installato quindi tranquillo e fiducioso ho pensato, ok seguo la procedura di devil e in ALTRI 3 minuti è fatta!
invece nulla ho provato su 5-6 diverse versioni di attract mode e non riesco ad installare il driver su nessuna, quindi h pensato di fare un merge tra la mia installazione pulita retropie 4.2 con driver GPIO e una con attract mode, e prendendo un pò di roba di qua e un pò di là senza avere una prercisa idea, ma cercando di capire cosa fosse utile, e pian piano ho ottenuto qualcosa di funzionante, perlomeno fino al joystick perchè poi mi sono accorto che i video in alcuni emulatori si bloccano, e sempre documentandomi ho scoperto che è un problema del codec video nel menù general ce deve essere impostato su MMAL, ma in tutte le immagini attract mode che ho scaricato non c'è questa voce, c'è solo la voce SOFTWARE.
Quindi tramite guide e tutorial ho provato a fixare il problema, ma dopo decine di tentativi non ho ancora risolto nulla, dopo la ricompilazione dell' attract mode come consigliato in molte guide, smette di funzionare anche il joystick e perlopiù il codec non si installa.
Ho trovato una immagine con il codec MMAL installato, ma di contro non ha il driver GPIO, e pur volendo fare di nuovo un merge con la mia immagine retropie+GPIO ho notato che le strutture delle cartelle sono sempre diverse e capire cosa devo prendere dall'immagine attract mode per inserirla nell'altra è complicato.
Spero che qualcuno oltre a chi mi ha già gentilmente risposto sugli altri post, abbia una soluzione a questo mio problema che poi credo sia anche di altri e che quindi ci renderebbe tutti più felici e meno nervosi :D


tulipo
Newbie
Newbie
Messaggi: 75
Iscritto il: 28/03/2017, 14:49
Reputation: 0
Città: Spoleto

Re: PROBLEA Retropie+Attrct Mode+ Driver GPIO

Messaggio da tulipo » 27/08/2017, 16:27

Sul sito di arcadepunks c'è una sezione solo per il raspberry. Prova a scaricare hyperpie base dove dovrai scaricare i rom pack e copiarli oppure prova le immagini di madlittlepixel. Abbrievate con MLP. Hyperpie da 128gb by MLP funziona molto bene.

Sent from my MI 5s using Tapatalk

My build:
Mini bartop : https://goo.gl/pQ8CDt
Raspyzero: https://goo.gl/neHcAk
Raspybox: https://goo.gl/J5zsbc


artfunk
Affezionato
Affezionato
Messaggi: 187
Iscritto il: 08/03/2013, 14:08
Reputation: 0
Città: Roma

Re: PROBLEA Retropie+Attrct Mode+ Driver GPIO

Messaggio da artfunk » 27/08/2017, 21:30

Purtroppo non ho una sd da 128 gb, o meglio l'avevo ma era difettosa comunqeu ho scaricato un' immagine Mad ma il driver GPIO non si installa nemmeno lì, di positivo c'è che ha il codec mmal, ma senza driver ci faccio poco.


tulipo
Newbie
Newbie
Messaggi: 75
Iscritto il: 28/03/2017, 14:49
Reputation: 0
Città: Spoleto

Re: PROBLEA Retropie+Attrct Mode+ Driver GPIO

Messaggio da tulipo » 27/08/2017, 22:42

Neanche il retrogame di adafruit si installa li ???

Sent from my MI 5s using Tapatalk

My build:
Mini bartop : https://goo.gl/pQ8CDt
Raspyzero: https://goo.gl/neHcAk
Raspybox: https://goo.gl/J5zsbc


artfunk
Affezionato
Affezionato
Messaggi: 187
Iscritto il: 08/03/2013, 14:08
Reputation: 0
Città: Roma

Re: PROBLEA Retropie+Attrct Mode+ Driver GPIO

Messaggio da artfunk » 27/08/2017, 23:30

Ora non ricordo su quale l'ho provato perchè ho fatto talmente tante prove che sono fuso, però domani ci provo e ti dico.


artfunk
Affezionato
Affezionato
Messaggi: 187
Iscritto il: 08/03/2013, 14:08
Reputation: 0
Città: Roma

Re: PROBLEA Retropie+Attrct Mode+ Driver GPIO

Messaggio da artfunk » 28/08/2017, 11:10

Aggiornamento
armato di tanta pazienza mi son messo a fare il merge tra la mia configurazione retropie 4.2 e un'immagine attract mode e il risultato è che ho il joystick finalmente funzonante e attract mode da configurare, resta ancora il problema del codec mmal che per ora ho risolto convertendo i video che si bloccavano.


tulipo
Newbie
Newbie
Messaggi: 75
Iscritto il: 28/03/2017, 14:49
Reputation: 0
Città: Spoleto

Re: PROBLEA Retropie+Attrct Mode+ Driver GPIO

Messaggio da tulipo » 28/08/2017, 11:25

Alleluia......

Sent from my MI 5s using Tapatalk

My build:
Mini bartop : https://goo.gl/pQ8CDt
Raspyzero: https://goo.gl/neHcAk
Raspybox: https://goo.gl/J5zsbc


artfunk
Affezionato
Affezionato
Messaggi: 187
Iscritto il: 08/03/2013, 14:08
Reputation: 0
Città: Roma

Re: PROBLEA Retropie+Attrct Mode+ Driver GPIO

Messaggio da artfunk » 28/08/2017, 11:29

tulipo ha scritto:
28/08/2017, 11:25
Alleluia......

Sent from my MI 5s using Tapatalk
ho appena riscontrato un piccolo problema, in attract mode non mi mantiene la configurazione del joystick, o meglio nel menu controlli i tasti sonoquelli assegnati da me ma il joy non funziona devo ricancellare le assegnazioni e rifarle.
Idea d cosa possa essere?


artfunk
Affezionato
Affezionato
Messaggi: 187
Iscritto il: 08/03/2013, 14:08
Reputation: 0
Città: Roma

Re: PROBLEA Retropie+Attrct Mode+ Driver GPIO

Messaggio da artfunk » 28/08/2017, 11:57

artfunk ha scritto:
28/08/2017, 11:29
tulipo ha scritto:
28/08/2017, 11:25
Alleluia......

Sent from my MI 5s using Tapatalk
ho appena riscontrato un piccolo problema, in attract mode non mi mantiene la configurazione del joystick, o meglio nel menu controlli i tasti sonoquelli assegnati da me ma il joy non funziona devo ricancellare le assegnazioni e rifarle.
Idea d cosa possa essere?
ora funziona


tulipo
Newbie
Newbie
Messaggi: 75
Iscritto il: 28/03/2017, 14:49
Reputation: 0
Città: Spoleto

Re: PROBLEA Retropie+Attrct Mode+ Driver GPIO

Messaggio da tulipo » 28/08/2017, 23:51

Mi raccomando fai il backup di questa scheda.... Non si sa mai....

Sent from my MI 5s using Tapatalk

My build:
Mini bartop : https://goo.gl/pQ8CDt
Raspyzero: https://goo.gl/neHcAk
Raspybox: https://goo.gl/J5zsbc


Rispondi