Pagina 2 di 4

Re: Novizio..problema pulsantiera

Inviato: 18/12/2017, 17:02
da tatofuma
cip060 ha scritto:
18/12/2017, 14:01
DIREI PROPRIO DI SI CHE CAMBIA!!
Uno e' il segnale del micro e l'altro e' la massa!!
considera che le masse nere se le controlli con il tester sono collegate tutte in parallelo quindi in teoria ne basterebbe solo uno collegato (ovviamente mettendo il filo della massa in serie su ogni micro dei pulanti!!
Ok, ma non ne vengo fuori. Se inverto i fili il risultato non cambia.
Allego due immagini per spiegare come ho collegato, ditemi se sbaglio.
interfaccia_LI.jpg
20171218_165436[237]_LI.jpg

Re: Novizio..problema pulsantiera

Inviato: 18/12/2017, 17:03
da cip060
Non conosco quei pulsanti io ho quelli on il micro diverso
Immagine

Re: Novizio..problema pulsantiera

Inviato: 18/12/2017, 21:45
da tatofuma
Da quello che ho capito I connettori sono:

1:dati on
2:gnd
3:led +
4:gnd

Ma se invertono i cavetti 1 e 2, il pulsante funziona lo stesso

Re: Novizio..problema pulsantiera

Inviato: 18/12/2017, 22:00
da Tox Nox Fox
Esatto
Io ho due pin ed i cavi sono singoli a due fili. Se li inverti non cambia nulla.

Re: Novizio..problema pulsantiera

Inviato: 18/12/2017, 22:09
da tatofuma
Non so cos altro provare

Re: Novizio..problema pulsantiera

Inviato: 19/12/2017, 12:02
da cip060
Rifai la configurazione dei tasti!!
Probabilmente il retropie che hai scaricato ha i tasti configurati in un altro modo!!!
un opzione di retropie appare premendo un pulsante e puoi riconfigurare i tasti uno ad uno usando il TUO JOYSTICK!!
eventualmente cancelli il file config mettendo la sd nel pc (Vede solo quella partizione) lo cancelli e accendi di nuovo retropie e creera la configurazione base chiedendoti di configurare i pulsanti tenendo premuto un pulsante per qualceh secondo

Re: Novizio..problema pulsantiera

Inviato: 19/12/2017, 13:11
da tatofuma
L ho fatto.. Il problema è che che anche durante la configurazione ho problemi.. Si premono pulsanti da soli, o il solito movimento a sinistra. Magari qualche pulsante è danneggiato, sto pensando di acquistare un nuovo set, magari di qualità maggiore. Anche qui accetto consigli

Re: Novizio..problema pulsantiera

Inviato: 19/12/2017, 14:15
da loredebby
controlla a modo i collegamenti dei microswitch...a me era capitata la solita cosa dello "spostamento casuale" destra e sinistra senza che toccassi niente....avevo semplicemente invertito un cavo su una leva e questo mi creava il conflitto...una volta collegato a modo il problema è sparito

Re: Novizio..problema pulsantiera

Inviato: 19/12/2017, 15:14
da Papero
Altro consiglio: stacca tutti i pulsanti dalla scheda e configura il joystick da solo. Se funziona, inizia ad attaccare un tasto per volta, fino a quando non trovi quello difettoso. Se invece hai problemi già dal joystick, allora stacca un cavetto per volta così riesci ad individuare quale microswitch è difettoso/collegato male.

Re: Novizio..problema pulsantiera

Inviato: 20/12/2017, 0:24
da tatofuma
Vi terrò informati.. Grazie ancora per i vostri consigli