Pagina 1 di 2

Pulsanti/joystick non riconosciuti da raspberry (gpio).

Inviato: 02/01/2018, 18:26
da goldrake74
Ciao a tutti, buon Anno! <-thumbup->
Prima di assemblare il mio primo bartop con una scatola di cartone pesante ho provato a connettere tutti i pulsanti e joystick al raspberry 3 per prendermi avanti con il lavoro, visto che mi devono consegnare i pezzi di legno...
Accendo il tutto, va avanti la schermata del raspbeery e arriva ad un certo punto e mi dive: "welcome NO GAMEPADS DETECTDED hold a button on your device to configure it press F$ to quit at any time." :on_cry:
Prendo un'altra SD e vado a scrivere la versione "vecchia" retropie-4.2-rpi2_rpi3.img ma il problema si ripresenta...
Per il collegamento ho utilizzato un cavo ide 40 fili e ho seguito lo schema che già si trova in questo forum GPIO.
Chi riesce a darmi una mano? <-help2->
Grazie

Re: Pulsanti/joystick non riconosciuti da raspberry (gpio).

Inviato: 02/01/2018, 19:21
da krosa
Ciao,

Premesso che senza sapere la tua configurazione e che driver GPIO stai usando risulta difficile capire la problematica posso provarci...

Sei sicuro di non stare usando GPIO in emulazione tastiera ?
Al punto in cui ti dice "welcome NO GAMEPADS DETECTDED hold a button on your device to configure it press F$ to quit at any time." hai provato tenere premuto un pulsante del joystick ? Se compare keyboard allora devi semplicemente mappare i tasti poichè il sistema vede i gpio come tastiera e non come gamepad/joystick.

Re: Pulsanti/joystick non riconosciuti da raspberry (gpio).

Inviato: 02/01/2018, 19:27
da boogs
Prova a verificare se i driver sono prima installati e poi caricati.


Inviato dal mio iPhone utilizzando Tapatalk

Re: Pulsanti/joystick non riconosciuti da raspberry (gpio).

Inviato: 02/01/2018, 19:34
da goldrake74
Grazie, mi sà che mi sono perso qualcosa... :?
Io ho caricato l'immagine sulla SD, e poi stop! Devo caricare dei driver? <-flag_of_truce->
C'è eventualmente una guida?
(ho schiacciato tutti i pulsanti/joystick alla comparsa della schermata ma non succede nulla...)

Re: Pulsanti/joystick non riconosciuti da raspberry (gpio).

Inviato: 02/01/2018, 22:15
da boogs
I driver devo essere installati. Nelle ultime release lo si può fare direttamente dal menu di retropie.


Inviato dal mio iPhone utilizzando Tapatalk

Re: Pulsanti/joystick non riconosciuti da raspberry (gpio).

Inviato: 03/01/2018, 9:00
da goldrake74
Grazie krosa e boogs!
Quindi provo a collegare una tastiera usb, collego il raspberry alla rete e cerco la voce driver?

Re: Pulsanti/joystick non riconosciuti da raspberry (gpio).

Inviato: 04/01/2018, 7:48
da goldrake74
Ciao, dopo aver caricato i driver non con poca fatica, all accensione mi esce che trova 2 joystick.
Bene, mi dice di configurarlo, assegno tutti i tasti, però c'è ne sono ancora sullo schermo, e non mi fa andare avanti.
Mi pare tasto trigger e altri... Si possono bypassare?
Una volta fatta la configurazione bisogna memorizzare oppure ogni volta andrà assegnato ogni tasto?
Grazie!

Re: Pulsanti/joystick non riconosciuti da raspberry (gpio).

Inviato: 04/01/2018, 18:51
da Tox Nox Fox
tieni premuto un tasto di quelli già configurati.. di solito la A.. e passa alla voce successiva non assegnando il tasto

Re: Pulsanti/joystick non riconosciuti da raspberry (gpio).

Inviato: 04/01/2018, 23:56
da goldrake74
Grazie Tox Nox Fox, <-thumbup-> basta tenere premuto un tasto per più secondi e passa al successivo.
Pensavo tutto più semplice... <-dry-> c'è ancora strada da fare....

Re: Pulsanti/joystick non riconosciuti da raspberry (gpio).

Inviato: 06/01/2018, 15:09
da loredebby